Anasayfa | Akademik Forum | Sizden Gelenler | Sipariş
Menü Açıklamaları
Sorular - Cevaplar
Makaleler
Makrolar
Yerleşik İşlevler
Animasyonlar
Yumurtalar
Fonksiyonlar
MTK Programlar
ExcelCE
Dosya İndir
Neler Yaptık?
İletişim
Sorular - Cevaplar
Soru-Cevap: 67 - M. Temel Korkmaz

YTL ve YKR'yi ayrı hücrelerde yazarak toplatmak.

Telefonlar ile gelen bazı acil sorularda, YTL ve YKR'nin ayrı hücrelerde toplatılması isteniyor fakat bunların irtibatlı olması da isteniyordu. Memur arkadaşlarımızın sorularına verdiğimiz cevabı burada açıklamalı olarak anlatıyorum.

A1 ve A2 hücrelerine YTL değerleri giriyoruz ve bunları A3 hücresinde hesaplatıyoruz. Bunun için A3 hücresine yazdığımız formül aşağıdaki gibidir.

=TOPLA(A1:A2)

B1 ve B2 hücrelerine de bu değerlerin Kuruş kısmını giriyoruz ve B3 hücresine aşağıdaki gibi yazdığımız formül ile toplatıyoruz.

=TOPLA(B1:B2)

Örnek resimde sizinde gördüğünüz gibi YTL birimi A3 içerisinde YKR birimi de B3 içerisinde normal olarak toplandı. Ancak biz biliyoruz ki, en büyük YKR tutarı 99 olmalıdır. Çünkü 100 YKR, 1 YTL'ye eşittir. Dolayısı ile her 100 YKR A3 hücresine aktarılmalı ve B3 hücresinden düşürülmelidir. O halde ilk olarak B3 hücresindeki değeri virgüllü formata sokarak net durumu görelim. Bunun için yapılması gereken en basit şey B3 hücresindeki formülü 100'e bölmektir.

=TOPLA(B1:B2)/100

Böylece sonucun 1,03 olduğunu göreceğiz. İşte A3 hanesine geçmesi gereken sayı virgülden önceki 1 rakamıdır. B3 hücresinde ise 0,03 rakamı kalacak. Şimdi ilk olarak B3 hücresinden 100 YKR'den fazlasını çıkartacak olan formülü yazalım.

=EĞER(TOPLA(B1:B2)>=100;TOPLA(B1:B2)/100-TAMSAYI(TOPLA(B1:B2)/100);TOPLA(B1:B2)/100)

yazdığımız formül çok basit. Eğer B1:B2 toplamı 100'e eşit ya da 100'den büyük ise B1:B2'yi topla, 100'e böl ve bu toplamın tamsayı kısmını çıkar. Eğer 100'den büyük ya da eşit değilse B1:B2'yi topla ve 100'e böl.

Geriye kalan sadece A3 hücresine çıkarılan tamsayı kısmını eklemektir. Onun için de Aşağıdaki aynı mantığı içeren formülü yazıyoruz.

=EĞER(TOPLA(B1:B2)>=100;TOPLA(A1:A2)+TAMSAYI(TOPLA(B1:B2)/100);TOPLA(A1:A2))

Her ne kadar bizim verdiğimiz örnekte tamsayı kısmı en fazla 1 olabilecekse de yazdığımız formül çok satırlı çalışmalar içindir. Sonuç aşağıdaki gibi olacaktır.

Evet, böylece YTL ve YKR'nin matematiksel olarak toplanma işlemi tamamlandı. Sıra işin görünümüne geldi. Sorunlarına acil cevap isteyen  arkadaşlarımız B3 hücresindeki görünümün 0,03 şeklinde değil de sadece kalan kuruş şeklinde görünmesini istiyorlardı.

Şimdi B3 hücresine bakalım. Görüntülenmesi istenen değer 3 YKR. Ancak bunun sadece 3 değil 03 şeklinde görüntülenmesi isteniyor. Şunu kesinlikle biliyoruz ki 03 diye bir sayı yok. Dolayısı ile Excel'de bu durumlarda hücreye 03 değil sadece 3 yazıyor. Bunu gösterebilmenin ise tek bir yolu var. O da B3 hücresindeki değeri sayı biçiminden çıkarıp, metin biçimine dönüştürmek.

Yapmamız gereken ise formülümüze metinsel işlemlerde kullandığımız PARÇAAL işlevini eklemektir. Bunun için aşağıdaki formülü B3 hücresine yazmanız yeterli olacaktır.

=PARÇAAL(EĞER(TOPLA(B1:B2)>=100;TOPLA(B1:B2)/100-TAMSAYI(TOPLA(B1:B2)/100);TOPLA(B1:B2)/100);3;2)

Artık sayısı nasıl hücrenin sağ tarafına yaslayacağınızı siz biliyorsunuz.

Destek
M.ÖZTÜRK - Y.KARAMAN
Bu siteyi, "Hayatını çocuklarının Ahlâklı ve Dürüst yetişmesi için harcamış olan Cefakar ve Fedakar, Canım ANNEM'e adadım."
Copyright © 1998-2011 M. Temel Korkmaz - Tüm hakları saklıdır.