Anasayfa | Akademik Forum | Sizden Gelenler | Sipariş
Menü Açıklamaları
Sorular - Cevaplar
Makaleler
Makrolar
Yerleşik İşlevler
Animasyonlar
Yumurtalar
Fonksiyonlar
MTK Programlar
ExcelCE
Dosya İndir
Neler Yaptık?
İletişim
ExcelCE
101 Soru ve Cevap: 27- Uğur Yurter - 10.03.2007

Sütunun Solundaki Verileri Aramak
Excel günlük hayatımızı kolaylaştıran kolaylıklar sunar. Düşeyara işlevi bunlardan biridir. Ancak bazı durumlarda, şunu da neden düşünmemişler dediğimiz olur. Yine Düşeyara işlevine göre bir örnek vermek istersek, “Aranan değer, başvurulan değerin sağındaki değil de, solundaki değer olsaydı bu işlevi nasıl kullanırdık.” Öyle sanıyorum ki 2003 sürümüne kadar Düşeyara işlevinin tek başına böyle bir özelliği yok. O zaman iş bize düşüyor ve Excel’in diğer işlevlerinin bir karışımı ile bu çözüme ulaşabiliyoruz.

Resimdeki gibi bir listemiz olduğunu, E2 hücresine kişilerin No’sunu girdiğimizde bize Ad ve Soyadın yan taraftaki hücrelerde vermesini isteyelim. Eğer No en A sütununda olsaydı işimizi Düşeyara işlevi ile çözüyorduk. Ancak No, C Sütununda olduğu için F2 hücresine

=İNDİS(A2:A3;KAÇINCI(E2;C2:C3;);1)

formülünü yazarak Adı, G2 hücresine

=İNDİS(B2:B3;KAÇINCI(E2;C2:C3;);1)

formülü yazarak da Soyadını aratabilmekteyiz  

Destek
M.ÖZTÜRK - Y.KARAMAN
Bu siteyi, "Hayatını çocuklarının Ahlâklı ve Dürüst yetişmesi için harcamış olan Cefakar ve Fedakar, Canım ANNEM'e adadım."
Copyright © 1998-2011 M. Temel Korkmaz - Tüm hakları saklıdır.